RETROBAT Board
Would you like to react to this message? Create an account in a few clicks or log in to continue.

[ENG] Bugs feedback

+4
getupor
Kilmech
Drodrik
Lorenzolamas
8 posters

Go down

[ENG] Bugs feedback Empty [ENG] Bugs feedback

Post by Lorenzolamas 28/08/21, 02:15 pm

If you find any bugs with BatGui.exe, please report them here, and specify which version you are using. Thumb up


In case of corruption of the es_system.cfg file, (4.0.2) you will find the latest version HERE



To be placed in the folder \emulationstation\.emulationstation
Lorenzolamas
Lorenzolamas
Admin

Messages : 1616
Date d'inscription : 2019-07-28

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Drodrik 26/09/21, 12:11 am

Hi again I'm here for this: https://retrobat.forumgaming.fr/t692-how-do-i-put-prboom-tyrquake-cave-history-under-ports-system#4068

I have the same problem again, the option option "Grouped Systems" in not under collection settings, so I discover the reason, I think there is a little bug with the Batgui, because if I change something like a ROM folder path, when I save for an extrange reason in the es_systems.cfg all the entries that contains "<group> /group>" are deleted check out the images:

A new es_systems.cfg archive from a new installation:
[ENG] Bugs feedback Bug110

I would like to change the path folder in this case psx system
[ENG] Bugs feedback Bug210

I save changes
[ENG] Bugs feedback Bug310

No if I check  es_systems.cfg again, is complety different and all the <group> </group> are deleted
[ENG] Bugs feedback Bug410

I can put the paths manually inside the es_systems.cfg, without issues so I consider this is a little bug with batgui, I hope you this info will be helpfull, and thanks for this software!
Drodrik
Drodrik

Messages : 5
Date d'inscription : 2021-09-07

Lorenzolamas likes this post

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Lorenzolamas 03/10/21, 06:40 pm

@Drodrik it's good now.
Lorenzolamas
Lorenzolamas
Admin

Messages : 1616
Date d'inscription : 2019-07-28

Back to top Go down

[ENG] Bugs feedback Empty BatGui Error

Post by Kilmech 05/11/21, 03:37 am

Hello!!!

I Tried enter in The BatGui.exe but appear the Message

" Erreur de liaison sur le champ source <SAI_GL_Cover>.
L'objet dynamique 'oJeuxTemp' n'a pas encore été alloué "

How can i Fix It
Kilmech
Kilmech

Messages : 2
Date d'inscription : 2021-11-05

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Lorenzolamas 05/11/21, 07:41 pm

Hello,

Could you make us a screenshot?
Lorenzolamas
Lorenzolamas
Admin

Messages : 1616
Date d'inscription : 2019-07-28

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Kilmech 10/11/21, 03:21 am

[ENG] Bugs feedback Sem_tz11
Kilmech
Kilmech

Messages : 2
Date d'inscription : 2021-11-05

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Lorenzolamas 10/11/21, 08:49 pm

Thank you.

poke @reppa
Lorenzolamas
Lorenzolamas
Admin

Messages : 1616
Date d'inscription : 2019-07-28

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by getupor 04/01/22, 09:23 am

@reppa
Copie du post sur Discord


Some problems encountered in version 4.02:
- Bat GUI writing to es_system.cfg will generate a lot of duplicate data
For example: .7z .zip =>.7z .zip .7z .zip .7z .zip .7z .zip
- When Bat GUI saves the gamelist, some languages will appear garbled. For example, the system is GB coded
Some problems encountered in version 4.02:
- Bat GUI writing to es_system.cfg will generate a lot of duplicate data
For example: .7z .zip =>.7z .zip .7z .zip .7z .zip .7z .zip
- When Bat GUI saves the gamelist, some languages will appear garbled. For example, the system is GB Coded


[ENG] Bugs feedback Modo
getupor
getupor

Messages : 301
Date d'inscription : 2020-10-04

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Reppa 06/01/22, 09:33 am

Hum weird, cause

Bat GUI writing to es_system.cfg will generate a lot of duplicate data < batgui never touch the file (on the older version yes, but since 2 or 3 months, it only write es_system_custom.cfg. And i'm 99% sure i already corrected this bug so strange.

When Bat GUI saves the gamelist, some languages will appear garbled. For example, the system is GB coded < ok i look at this one !

Thank's for the feedback, sorry my late answer i didn't get any notification email, need to check if i've deactivated the thing xD

Edit : Did you know which version he used, cause all those bugs in my memory are already corrected with update, so maybe he's using an old version, cause actually, batgui don't write anymore data in the Es_system.cfg, it always in a es_system_custom.cfg, so if batgui write in the wrong, that cause it's the older version he use !


________________________

-= BatGui.exe Creator =-
[ENG] Bugs feedback Modo
Reppa
Reppa

Messages : 12
Date d'inscription : 2021-07-07

Back to top Go down

[ENG] Bugs feedback Empty BatGui: not finding -images, -marquee, -thumb and -video

Post by MartyKong 11/01/22, 05:40 am

Hi, BatGui finds the games with matching system extensions and when in the gamelist editor tab, clicking on them loads them in the Name & Path section. I also have a Video Folder (-video) and Images Folder (-images, -marquee, -thumb). These are not automatically loaded in the Image, Video, Marquee and Thumbnail sections so saving a gamelist doesn't include them.

<?xml version="1.0" encoding="UTF-8"?>
<gameList>
<game>
<path>./After Burner III (USA).chd</path>
<name>After Burner III (USA)</name>
<rating>0</rating>
<releasedate>20220110T000000</releasedate>
<kidgame>false</kidgame>
<lastplayed>20220110T000000</lastplayed>
<gametime>0</gametime>
<playcount>0</playcount>
<players>0</players>
<hidden>false</hidden>
</game>
</gameList>
                             But should look like this:
<?xml version="1.0"?>
<gameList>
<game>
<path>./After Burner III (USA).chd</path>
<name>After Burner III</name>
<image>./images/After Burner III (USA)-image.png</image>
<video>./videos/After Burner III (USA)-video.mp4</video>
<marquee>./images/After Burner III (USA)-marquee.png</marquee>
<thumbnail>./images/After Burner III (USA)-thumb.png</thumbnail>
<rating>0</rating>
<releasedate>19920101T000000</releasedate>
<kidgame>false</kidgame>
<lastplayed>20220110T000000</lastplayed>
<gametime>0</gametime>
<playcount>0</playcount>
<players>0</players>
<hidden>false</hidden>
</game>
</gameList>

I am hoping to use the Gamelist Editor to find the games, Video's and Images and generate a matching .xml. What am I doing wrong? Thanks again.
MartyKong
MartyKong

Messages : 4
Date d'inscription : 2022-01-11

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Reppa 11/01/22, 12:12 pm

MartyKong wrote:Hi, BatGui finds the games with matching system extensions and when in the gamelist editor tab, clicking on them loads them in the Name & Path section. I also have a Video Folder (-video) and Images Folder (-images, -marquee, -thumb). These are not automatically loaded in the Image, Video, Marquee and Thumbnail sections so saving a gamelist doesn't include them.
I am hoping to use the Gamelist Editor to find the games, Video's and Images and generate a matching .xml. What am I doing wrong? Thanks again.

Please update batgui to the lastet version, you seems to use a very old version !

Marquee / Video and thumnail are managed since Summer 2021 Wink

[ENG] Bugs feedback Batgui10

Please find the link here : BatGui.exe

Juste overwrite the one over retrobat, or just do the update at the start of batgui (it will propose the update, if you're connected to internet indeed)


________________________

-= BatGui.exe Creator =-
[ENG] Bugs feedback Modo
Reppa
Reppa

Messages : 12
Date d'inscription : 2021-07-07

Lorenzolamas likes this post

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by MartyKong 11/01/22, 04:13 pm

Thanks for your reply. I downloaded it yesterday and updated it. I'll try updating again. Mine looks just like your photo if it's reading a completed correct gamelist.XML file. If you add some new games, Images and Video folders to the system ROM folder it finds the name and path but the image, video, marquee and thumbnail lines are left blank even though there are images.PNG and video.mp4 in their folders. When you save the gamelist.XML they are therefore missing? I'll update, remove the old gamelist.xml and try rerunning the gamelist editor to see if it can generate a complete gamelist. Thanks again:)
MartyKong
MartyKong

Messages : 4
Date d'inscription : 2022-01-11

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by MartyKong 12/01/22, 03:09 am

Ok Reppa, I ran the Batgui updater. I then put a Segacd game - After burner 3 (USA),  In the video folder - After Burner III (USA)-video and in the Images folder - After Burner III (USA)-image, After Burner III (USA)-marquee and   After Burner III (USA)-thumb all in the segacd Roms folder. My hope is after clicking "save gamelist" I would have a complete gamelist with all images and video included. Is there a way to have Batgui search the  Images and video folders as well as the game. This way I can quickly add a few new games, vids and images and generate a gamelist for it. Thanks for having a look.
[ENG] Bugs feedback <a href=[ENG] Bugs feedback Game-list-editor [ENG] Bugs feedback Gamelist [ENG] Bugs feedback Images [ENG] Bugs feedback Segacd" />
MartyKong
MartyKong

Messages : 4
Date d'inscription : 2022-01-11

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Reppa 12/01/22, 08:18 am

Ok ok i see, so batgui was not able to auto find the file, he doesn't do that, cause they're too many "case"

For some people, they have like me, multiple directory where the file as the exact name of the roms. Here you have all files in one directory with an "-xxxx" at the end, hum, i need to think about it Smile.

It can be a good improvement. Can i keep in touch with you and send you later this week an updated version for you to test that ?

I'll contact you in pm when i've a working version ^^



________________________

-= BatGui.exe Creator =-
[ENG] Bugs feedback Modo
Reppa
Reppa

Messages : 12
Date d'inscription : 2021-07-07

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by MartyKong 12/01/22, 09:32 pm

Of course, I would be happy to test. Very much appreciated.
MartyKong
MartyKong

Messages : 4
Date d'inscription : 2022-01-11

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by getupor 13/03/22, 07:30 pm

Hello @Reppa

Not a bug, but a request on Discord.
For gamelist editor, add predefine path for /images and /videos (like the internal scrapper path).

https://discord.com/channels/748519802255179917/763445938098143252/952630273672118323


[ENG] Bugs feedback Modo
getupor
getupor

Messages : 301
Date d'inscription : 2020-10-04

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by marcoabm 30/04/22, 05:48 pm

Hello everyone, I hope you are well!

I'm going through my process of configuring the games on the mini-pc I'm building for myself and my grandson, and I ran into a problem putting the Nintendo WiiU games on the RetroBat list.
I added the games and they appear in the list, with the launcher name of each game. Following some research I did, I saw that it is necessary to manually change the gamelist.xml using BatGui, but when accessing the games list it displays the following message, and exits the program:

Code:
Error at line 1 of Méthode ChargeListeJeux process.
A fatal error occurred on the 'DocumentXML' element (of 'xmlDocument' type) and prevents from using it.
This error occurred at line 22 of the 'Constructeur de la classe cPlateforme' process.
The XML document has not been loaded.

System error details:

Row 16, Column 19: Input is not proper UTF-8, indicate encoding !
Bytes: 0x99 0x20 0x57 0x6F

Row 56, Column 16: xmlParseEntityRef: no name


----- Technical information -----

Project : BatGui

WL call:
Process of 'Méthode ChargeListeJeux' (cPlateforme.ChargeListeJeux), line 1

What happened?
A fatal error occurred on the 'DocumentXML' element (of 'xmlDocument' type) and prevents from using it.
This error occurred at line 22 of the 'Constructeur de la classe cPlateforme' process.
The XML document has not been loaded.

Error code: 40057
Level: fatal error

System error message:
Row 16, Column 19: Input is not proper UTF-8, indicate encoding !
Bytes: 0x99 0x20 0x57 0x6F

Row 56, Column 16: xmlParseEntityRef: no name

Dump of the error of 'wd240xml.dll' module (24.0.110.0).
Additional information:
EIT_PILEWL :
Méthode ChargeListeJeux (cPlateforme.ChargeListeJeux), line 1
Constructeur de la classe cPlateforme (cPlateforme.Constructeur), line 25
Bouton gauche relâché (WM_LBUTTONUP) de ZR1_Plateforme (FEN_Main.ZR1_Plateforme), line 12
EIT_DATEHEURE : 30/04/2022 12:41:37
EIT_TYPE_WDFILE : <4>
EIT_IDCODE : <458752>

Help
marcoabm
marcoabm

Messages : 12
Date d'inscription : 2022-04-17
Age : 38
Localisation : Brazil

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Lorenzolamas 30/04/22, 06:01 pm

marcoabm wrote:Hello everyone, I hope you are well!

I'm going through my process of configuring the games on the mini-pc I'm building for myself and my grandson, and I ran into a problem putting the Nintendo WiiU games on the RetroBat list.
I added the games and they appear in the list, with the launcher name of each game. Following some research I did, I saw that it is necessary to manually change the gamelist.xml using BatGui, but when accessing the games list it displays the following message, and exits the program:


Hello,

"If you find any bugs with BatGui.exe, please report them here, and specify which version you are using."
Lorenzolamas
Lorenzolamas
Admin

Messages : 1616
Date d'inscription : 2019-07-28

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by marcoabm 01/05/22, 03:45 am

Sorry, i forgot Embarassed

My version is 1.7.40.0

One thing I forgot to mention was that the first time it worked (it showed the WiiU games list) but after I added other games the problem started..
marcoabm
marcoabm

Messages : 12
Date d'inscription : 2022-04-17
Age : 38
Localisation : Brazil

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by marcoabm 01/05/22, 04:21 am

Some more information to try to help:

I went to the ~\Retrobat\roms\wiiu\ folder and deleted the gamelist.xml file. I opened retrobat, went to the listing, and asked to scrape one of the games. I closed RetroBat.
I went to BatGui, and the GameList Editor menu opened the wiiu games without crashing, but it only showed 3 entries. I clicked the "show all game" button and after click on "save gamelist", and right after, it showed this message:

Code:
Error at line 17 of Procédure locale pSauveGameList process.
The dynamic object '' has already been deleted.

----- Technical information -----

Project : BatGui

WL call:
Process of 'Procédure locale pSauveGameList' (FEN_Main.PROCEDURE.pSauveGameList), line 17

What happened?
The dynamic object '' has already been deleted.

Error code: 2402
Level: fatal error

Dump of the error of 'wd240vm.dll' module (24.0.600.2).
Identifier of detailed information (.err): 2402
Debugging information:
Classe:VerifieValidite
Additional information:
EIT_PILEWL :
Procédure locale pSauveGameList (FEN_Main.PROCEDURE.pSauveGameList), line 17
Clic sur BTN_Save_Gamelist (FEN_Main.BTN_Save_Gamelist), line 9
EIT_DATEHEURE : 30/04/2022 23:17:51
EIT_TYPE_WDFILE : <2>
EIT_IDCODE : <458752>

Help
marcoabm
marcoabm

Messages : 12
Date d'inscription : 2022-04-17
Age : 38
Localisation : Brazil

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Reppa 01/05/22, 01:19 pm

Hell, thank's for the feedback, i'm in vacancies, i'll check all that as soon as i can Smile.

Probably next week, time to run some test and find what happen and why the object seems to no longer exist when you saved !






________________________

-= BatGui.exe Creator =-
[ENG] Bugs feedback Modo
Reppa
Reppa

Messages : 12
Date d'inscription : 2021-07-07

Lorenzolamas and marcoabm like this post

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by akide 20/05/22, 11:46 am

Hi.
Congratulations for the work done with Retrobat, I really like it.
However, I have some problems with BatGUI that I cannot resolve.
If I change the rom folder (arcade, for example) or if I try to set the Steam profile (configured privately, as explained in the FAQ) at that moment it seems ok and when save is confirmed that the saving was successful.
When I then close BatGUI and go to reopen it, all the changes have been lost.
Why?
akide
akide

Messages : 5
Date d'inscription : 2022-05-20

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Reppa 20/05/22, 12:46 pm

Hello, i'm currently moving from my house, i will look at that when i got some times

Steam information aren't saved at all, i don't keep the username.

If I change the rom folder (arcade, for example) < that shold be working fine, check the "es_system_custom.cfg" who overide what is in the Es_System.cfg Wink, i only write data in the "..._custom.cfg", the es_system for batgui is just here as a template for the custom.cfg

I'm not sur that answered your question, but for the moment i can't do more.


________________________

-= BatGui.exe Creator =-
[ENG] Bugs feedback Modo
Reppa
Reppa

Messages : 12
Date d'inscription : 2021-07-07

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by akide 20/05/22, 12:57 pm

Reppa wrote:Hello, i'm currently moving from my house, i will look at that when i got some times

Steam information aren't saved at all, i don't keep the username.

If I change the rom folder (arcade, for example) < that shold be working fine, check the "es_system_custom.cfg" who overide what is in the Es_System.cfg Wink, i only write data in the "..._custom.cfg", the es_system for batgui is just here as a template for the custom.cfg

I'm not sur that answered your question, but for the moment i can't do more.

Thank you but it doesn't work.
akide
akide

Messages : 5
Date d'inscription : 2022-05-20

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by getupor 20/05/22, 06:41 pm

akide wrote:Thank you but it doesn't work.

When reopening batgui, are you sure that you start from es_system_custom (which have been modified) and not es_system (the original) ?

[ENG] Bugs feedback HPUbWU3


[ENG] Bugs feedback Modo
getupor
getupor

Messages : 301
Date d'inscription : 2020-10-04

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by akide 20/05/22, 06:52 pm

getupor wrote:
akide wrote:Thank you but it doesn't work.

When reopening batgui, are you sure that you start from es_system_custom (which have been modified) and not es_system (the original) ?

[ENG] Bugs feedback HPUbWU3
Yes, I'am on es_system_custom, I'am sure.
akide
akide

Messages : 5
Date d'inscription : 2022-05-20

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by getupor 20/05/22, 07:13 pm

So, in between, go to
\RetroBat\emulationstation\.emulationstation\
Open es_systems_custom.cfg with notepad, and edit manually your path.


[ENG] Bugs feedback Modo
getupor
getupor

Messages : 301
Date d'inscription : 2020-10-04

Lorenzolamas likes this post

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by akide 20/05/22, 10:04 pm

getupor wrote:So, in between, go to
\RetroBat\emulationstation\.emulationstation\
Open es_systems_custom.cfg with notepad, and edit manually your path.
Thanks for your answer.
Honestly I had already arrived at that solution but I hope to be able to find a solution.
However, I will continue to try to understand the cause.
For now I have tried to uninstall and reinstall Retrobat on different partitions, disable all antivirus and protections and check that the files were not set to read only.
Unfortunately, nothing has served the purpose of making BatGUI work...
akide
akide

Messages : 5
Date d'inscription : 2022-05-20

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by akide 20/05/22, 11:53 pm

I noticed in BatGUI that if I change the roms folder by typing the address it works fine. The problem instead occurs when I choose the icon to change path (the one with the three dots)
akide
akide

Messages : 5
Date d'inscription : 2022-05-20

Back to top Go down

[ENG] Bugs feedback Empty Re: [ENG] Bugs feedback

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum