RETROBAT Board
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Black emulationstation screen

2 posters

Go down

Black emulationstation screen Empty Black emulationstation screen

Post by claudio.zergoni 11/12/21, 04:05 pm

Hello,
I have an old dig, a Sempron 1GHz with Radeon X1200 GPU, supporting OpenGL 2.1.

The OS is Win7 with all the dependencies installed - I think - and Retrobat 3.1 is running pretty well with bacic arcade and 16bit console emulators.
I was trying Retrobat 4.0.2, but emulationstation is showing a totally black window.
I tried disabling splash videos but nothing changed.

es_log.txt is as following:

2021-12-11 15:19:24 INFO EmulationStation - v31, built Jun 25 2021 - 00:58:42
2021-12-11 15:19:25 INFO Parsing XML file "C:/Users/RetroBat/RetroBat-4.0.2/emulationstation/resources/genres.xml"...
2021-12-11 15:19:25 ERROR Resource path not found: :/locale/it_IT/emulationstation2.po
2021-12-11 15:19:25 ERROR Resource path not found: :/locale/it_IT/LC_MESSAGES/emulationstation2.po
2021-12-11 15:19:25 ERROR Resource path not found: :/locale/lang/it_IT/emulationstation2.po
2021-12-11 15:19:25 ERROR Resource path not found: :/locale/lang/it_IT/LC_MESSAGES/emulationstation2.po
2021-12-11 15:19:25 ERROR Resource path not found: :/locale/it/emulationstation2.po
2021-12-11 15:19:25 INFO Window::init
2021-12-11 15:19:25 INFO Creating window...
2021-12-11 15:19:26 INFO Created window successfully.
2021-12-11 15:19:26 INFO GL vendor:   ATI Technologies Inc.
2021-12-11 15:19:26 INFO GL renderer: ATI Radeon X1200 Series
2021-12-11 15:19:26 INFO GL version:  2.1.8545 Release
2021-12-11 15:19:26 INFO GL shading:  1.20
2021-12-11 15:19:26 INFO GL exts:     GL_AMD_performance_monitor GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_envmap_bumpmap GL_ATI_fragment_shader GL_ATI_meminfo GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_vertex_array GL_KTX_buffer_region GL_NV_blend_square GL_NV_texgen_reflection GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_WIN_swap_hint WGL_EXT_swap_control
2021-12-11 15:19:26 INFO ARB_texture_non_power_of_two: ok
2021-12-11 15:19:26 ERROR GLSL Vertex Compile Error
Vertex shader failed to compile with the following errors:
ERROR: 0:1: '' :  Version number not supported by GL2
ERROR:  compilation errors.  No code generated.

I can guess that there is some problem with video driver and/or OpenGL version.
I was able to run retrobat 4 on other Win7 machines, despite not supported anymore, and I admit that this dig is very old too.
I am only wondering whether the minimum opengl version required to run emulationstation has changed from v3.1 to 4.0.2... (wasn't it version 2?) because retroarch itself has no problem to start and run properly with gl driver.

And also I would ask if there is some other setting or tip that I could try in order to see something in the emulationstation window.
Thank you very much in advance.

Best regards.
claudio.zergoni
claudio.zergoni

Messages : 2
Date d'inscription : 2021-12-11

Back to top Go down

Black emulationstation screen Empty Re: Black emulationstation screen

Post by Lorenzolamas 11/12/21, 07:33 pm

Hello,

Yes it is certainly because of the Open GL, as specified on the site, it should be at least in open GL 3.3.

Our version of Emulationstation is regularly updated.
Lorenzolamas
Lorenzolamas
Admin

Messages : 1650
Date d'inscription : 2019-07-28

claudio.zergoni likes this post

Back to top Go down

Black emulationstation screen Empty Re: Black emulationstation screen

Post by claudio.zergoni 11/12/21, 07:47 pm

Ok... I understand. Thank you for the reply, and keep up the good work! I wish you a merry christmas.
claudio.zergoni
claudio.zergoni

Messages : 2
Date d'inscription : 2021-12-11

Lorenzolamas likes this post

Back to top Go down

Black emulationstation screen Empty Re: Black emulationstation screen

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum