RETROBAT Board
Would you like to react to this message? Create an account in a few clicks or log in to continue.

[RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son)

2 posters

Go down

[RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son) Empty [RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son)

Post by Peax2dan 31/08/20, 11:31 am

Bonjour les gens.
J'ai monté un Retrobat fonctionnel sur un PC en W8.1. J'utilise un pad Xbox360 filaire. J'ai tenté un portage de ma config sur un autre PC et profité de la portabilité annoncé par retrobat dans toutes les videos de presentation ou autres conversations de blogs...
J'ai donc copié tout mon répertoire retrobat dans un DD ext, et lancé sur un PC en W10. je me confronte a deux problèmes:

- Problème 1 Bouton HotKey non fonctionnel :
W10 a par défaut ce bouton associé a des commandes de jeux ( windows game bar). j'ai désactive dans W10 la fonctionnalité ( https://www.malekal.com/desactiver-barre-jeux-windows10/) mais le bouton HotKey de mon PAD reste inutilisable, et même en config dans retrobat de la manette, le bouton n'est pas utilisable.
  => Est ce que qq d'entre vous à le même soucis? Il y a t'il une astuce que je ne connais pas?

- Problème 2 de son dans les jeux:
Le menu de sélection est ok, son nickel, vidéos dans les collection son nickel. Son des jeux Dreamcast OK (émulateur stand alone). Tous les autres jeux des collection, le son ne fonctionne pas une fois le jeu lancé.
  => Problème de driver audio W10? Est ce que qq d'entre vous à le même soucis? Il y a t'il une astuce que je ne connais pas?

PS: ces phénomènes se sont reproduits sur un troisième PC monté en W10 à jour...

Merci pour votre aide.


Last edited by Peax2dan on 01/09/20, 08:29 am; edited 1 time in total
Peax2dan
Peax2dan

Messages : 8
Date d'inscription : 2020-08-23

Back to top Go down

[RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son) Empty Re: [RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son)

Post by NickTamer 31/08/20, 12:47 pm

Pour le probleme N1 si tu configure ta manette sous Retrobat tu ne peux associé Hotkey sur une touche de ton choix, obligé d’utilisé celle par défaut (select me semble).
Dans ce cas il faut desactivé la config manette de Retrobat et configurer les touches de ton choix dans chaque émulateurs (pour le hotkey certain émulateur n'en utilise pas)

Pour le probleme n 2 quel sont les émulateurs concernés ?

Si c'est Retroarch essaye dans paramètre son de réglé le plug in audio sur "gl", au lieu de" xaudio"

Ca peux venir d'un probleme avec Xaudio2, tente la reinstallation, de Xaudio2 via la MAJ juin 2010
https://www.microsoft.com/en-us/download/details.aspx?id=8109
NickTamer
NickTamer

Messages : 151
Date d'inscription : 2020-02-21

Back to top Go down

[RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son) Empty Re: [RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son)

Post by Peax2dan 31/08/20, 02:32 pm

yop.
Merci pour tes réponses.
Poir N1: ok, mais il me semblais que le hotckey pouvait être affecté au bouton central du pad xbox. Je l ai fais sur le W8.1 au début, car j,avais foiré le mappage des boutons, j'ai du tout reconfigurer bouton par bouton. maintenant pour sortir des jeux je fais bouton central pad + start, et rentrer dans retroarch bouton central + A. Je retesterai avec le PC W10. Pour la piste du bouton select comme hotckey je regarderai aussi, il est possible de sortir des jeux en appuyant sur select+start (d'ou select est peut être bien le hotkey). Quid des jeux qui nécessitent le bouton select...
Pour N2: oui c'est ce que je pensais. Mais pour reconfigurer retroarch, tu le fais en lançant retroarch depuis l'arbo? ou directement dans retrobat (hotkey+ X)? En suite je fouillerai dans les menus.

je donnerai des nouvelles par la suite.
Peax2dan
Peax2dan

Messages : 8
Date d'inscription : 2020-08-23

Back to top Go down

[RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son) Empty Re: [RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son)

Post by NickTamer 31/08/20, 05:54 pm

Pour les hotkey pour ma part j'ai désactivé le mapping via Retrobat (option développeur), et dans Retroarch j'ai fait mon propre mapping avec select comme Hotkey (et select + start pour quitter Retroarch entres autres)
Je n'ai eu aucun souci avec cette config, select est juste la hotkey et j'utilise un second bouton pour validé, (exemple avance rapide Select +Gachette droite, rembobiné Select + Gachette gauche etc...)

Pour ton problème de son essai peut être d'abord d'installer la MAJ Juin 2010 pour Xaudio ça pourrai réglé totalement le problème et si ça ne fonctionne pas quand tu lance EmulationStation va sur Retrobat ----->Retroarch---->Et dans les menu de retroarch, section audio change le plug in (qui doit certainement par defaut être Xaudio et met le en gl)
NickTamer
NickTamer

Messages : 151
Date d'inscription : 2020-02-21

Lorenzolamas likes this post

Back to top Go down

[RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son) Empty Re: [RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son)

Post by Peax2dan 01/09/20, 08:29 am

Bonjour les gens!

Pb N1: à n'y rien comprendre hier soir je pouvais mapper mon bouton #10 du pad xb360, donc.... plus de pb. et merci pour l'explication du bouton select.

Pn N2 : Résolu en changeant le driver audio dans retroarch, la solution étais dans un autre post...

Merci encore pour votre travail et votre aide.
Peax2dan
Peax2dan

Messages : 8
Date d'inscription : 2020-08-23

Lorenzolamas likes this post

Back to top Go down

[RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son) Empty Re: [RESOLU] [W10] Problèmes avec Retrobat et Windows 10 (Hotkey / son)

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum